vsftpd: Error 553 – Could not create file OR login error 530

vsftpd:  Error 553 – Could not create file OR login error 530

Sample working vsftp.conf file

If that does not solve your problem then try running command-

“setenforce 0”

To have this setting even after reboot you need to create a file
$vi /etc/selinux/targeted/booleans.local

Add line

ftpd_disable_trans=1

Hope that will solve your problem.

This entry was posted in Unix/Linux and tagged . Bookmark the permalink.

One Response to vsftpd: Error 553 – Could not create file OR login error 530

  1. Mohan Cheema says:

    If the error is due to SElinux. Instead of “setenforce 0” i.e. disabling SElinux it is advisable to disable SElinux protection for FTP , from SElinux settings. For this you just have to run the following command “setsebool -P ftp_home_dir 1” without quotes. This commands makes selinux to allow ftp. Selinux is not disabled. It’s not recommended to disable Selinux

    Regards,

    Mohan

Leave a Reply